Front brakes 2

I have always disliked bleeding brakes. It seems unnecessarily tedious.

My friend Steve has a speed bleeder and offered to help me finish up the front brake on this thing, so I said, “hell yeah!”

Day 1 : I hadn’t fully screwed in the banjo bolt for the brake sending unit, so did that. Except that it wouldn’t screw in the whole way. Oh, the bolt is too long!
Okay, cut the bolt down. Where the hell is my hacksaw? I had three at one point. But after a couplea moves… seems I have none. Bother.
Steve took bolt home and was able to cut it down to the correct length.

Day 2: Got the banjo tightened in and the speed bleeder hooked up. Poured some brake fluid into the m/c and away we go!

Except that it didn’t go. “Should this be this slow with a speed bleeder?”
Maybe it’s just taking longer because it’s an unfouled brake line full of air?
hm.
Well, the brake lever is tightening up some. But should be firmer. And no more bubbles are presenting.
This is odd.
After making sure all the bolts were tight, found that one of the brake pads was wiggly. That’s not right!

I took the caliper off and discovered that one of the pistons wasn’t moving.
After closer inspection, it seems that when I rebuilt them, I pushed that caliper down too far and it went below the gasket.
User error!
The gasket was peeking out just enough to prevent the piston from moving. Der.

Got the rest of the caliper and brake line more secure.

My little compressor didn’t have enough oomph to blast the piston out, so Steve took it to his industrial compressor.

Hopefully, I’ll be able to finish the front brake after work today!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s